
 

PeakTech DGraph Software Getting Started 
Install Battery, Software & Driver according to User Manual. To use the data logger, take the following 

steps: 

1. Make sure the battery is correctly installed, or if you use USB port to power the data logger directly, you 

must not remove data logger from USB port when the data logger is logging. 

2. Insert the data logger into an available USB port of a PC which has installed the Data Logger Graph 

software and driver. 

3. Double click on the Data Logger Graph icon on your Windows desktop. This will load the Data 

Logger Graph software. On the left top of the software main screen, you can see Start  button and 

click on it. This will open Data Logger Device dialog.  

4. Select data logger device that will be set (or default). Here you can check the firmware version, status, 

etc. of the selected data logger device.  

5. Click on the Setup button to load Data Logger Setup dialog. Here you can follow the screen 

instructions and setup the data logger (or default if first attempts).  

6. Click on the Finished button. The data logger will start according to your settings. 

7. Remove the data logger from PC USB port except USB port will be used as power supply as your 

required. 

8. When a task is finished, you can download data to PC. Do according to step 2 to 4 above firstly, and 

then click on the Download button on the Data Logger Device dialog. Here you can follow the screen 

instructions to download and save the data to PC. Please note that you need to input correct password to 

operate this step if the data logger has been set a password before (No for factory default). 

9. You can use the Data Logger Graph software to graph, analyze and print the data, and export the data 

to other file formats (xls, txt, jpg, etc.). 

 

Data Logger Setup 
Double click on the Data Logger Graph icon on your Windows desktop. This will load the Data Logger 

Graph software. On the left top of the software main screen, you can see Start  button and click on 

it. This will open Data Logger Device dialog. 
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 Select Device: All connected data logger devices will be listed, and you can select a data logger 

device that will be set. Each data logger device has a serial number arranged by factory. Move and 

put the mouse on the LED button. You can see the yellow LED flash on the case of the selected data 

logger. The selected device information and status will be shown, including device description, 

firmware version, password exist, logger status and battery status. Click on the Refresh button, 

user can refresh the selected device information and status manually. 

Click “Details” button to see the details and status of the selected data logger. 

Click “Stop Logging” to stop current logging. 

Click “Start Logging” to start logging directly without re-setup. 

 

 Setup: Click on the Setup button to open Data Logger Setup dialog.  

Select the General tab. 

 

 

a. Logger Name. Name the data logger to give it a unique identity. 

b. Sample Rate. Select time interval to instruct the logger to log readings at a specific rate. 

c. Password. If user set a password for the data logger, it will need user to enter the password when 

download data. 

 

Then, select the Channel Settings tab. Here it lists all channel related settings. 
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a. Description. Name the channel. 

b. Status. Double-click to show a pop-up menu, and user can Enable or Disable the channel. 

 

 
c. Unit. Double-click to show a pop-up menu, and user can select the unit for the channel. 

d. Low Limit/ High Limit. Here allows user to set low/high alarm limit. 

e. LED Alarm. User can select or unselect to enable or disable LED Alarm when Logged readings exceed 

the low/high alarm limit. 

f. Alarm Hold. Tick Hold to continue indicating an LED Alarm condition even when the logged readings 

have been returned within the set alarm limit.  
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g. Sample Mode. When the sample rate is more than internal basic sample rate, the readings between 

sample rate interval will be processed as below 

-Instant. Ignore the readings between sample rate intervals. 

-Average. Get the average of all the readings between sample rate intervals. 

-Maximum. Get the maximum of all the readings between sample rate intervals. 

-Minimum. Get the minimum of all the readings between sample rate intervals. 
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h. Calibration. It can support up to two point calibration. Target is the value that will be calibrated. 

Actual is the actual value for target value. 

Important Note: Measurement error will occur if user does any calibration incorrectly. User 

can clear wrong calibration value. See the advanced tab for more details. 

User must input 0 for all target and actual if user don’t want to change any calibration 

settings. 

 

Then, Select the Start and Stop Method tab. 

 

a. Start Method. Select how or when to start logging. 

b. Stop Method. Select how to stop logging. Note that if user selects “Overwrite When Full”, user can 

stop logging via the button on the housing of data logger. 

c. Logging Duration. Indicate duration time under the settings. 
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Finally, select the Advanced tab. 

 

a. LED. User can enable or disable the green LED indication for logging status. 

b. LCD. If user ticks it, the LCD always on (Only for some specific product) 

c. Clear Calibration. User can reset and clear calibration that be set on data logger before. 

d. Select Thermocouple Type. Select thermocouple type for data logger (NOTE: Only for specific 

model) 

e. Alarm Phone Number. Click “SMS Alarm Phone Number Setup” button. Enter the mobile phone 

number via which you want to get the alarm message when SMS alarm appears. 5 mobile phone 

numbers available at most and please make sure the integrality and the accuracy of the input 

numbers, otherwise users can not receive the SMS normally. Meanwhile, users can query the Data 

Logger readings and battery status by dialing the Data Logger and this number will be written into the 

alarm number list automatically. Notice: the top mobile number in the 5 numbers list will be forced to 

delete if Data Logger being written more than 5 numbers. (NOTE: Only for specific model) 
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f. Alarm Delay. Users can select alarm delay. Data logger will start alarm after the selected delay 

time(NOTE: Only for specific model) 

 

Click on the Finish button to setup.  Press the Cancel button to abort the setup. 

 

Notes:  

- Any stored data will be permanently erased when Setup is finished. To ensure you to save this data 

before it is lost, click Cancel and then you need to download data. 

- The battery will likelihood run out before logger will have finished specified sample points. Always 

ensure that the remaining charge in the battery is sufficient to last the complete duration of your 

logging exercise. If in doubt, we recommend that you always install a fresh battery before logging 

critical data. 

- If user selects the “Start by Button”, please start logging manually. 
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Data Download 
On the left top of the software main screen, you can see Start       button and click on it. This will 

open Data Logger Device dialog. 

 

 

a. Select Device to download data. 

b. Click on the Download button and input password if existed, and a Save dialog will be shown. 

 

c. Specify the saved path and name the saved file. Click on the Save button to save data. 
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d. When downloading finished, a dialog below will be shown, and user click “Open” to open the 

downloaded file directly, or click “Add” to add the downloaded file to current graph, or click “Nothing” 

to exit.  

 

Realtime Readings 

When the data logger connected to PC, user can view the real-time readings.  
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Stop Logging 
User can click on the Stop button to stop logging if the data logger is logging. 

 

 

Logger Details 
Click on the Details button to view the information and status details for the data logger. 
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Software Interface 

 
 

The above picture show the following information: 

1. Standard Toolbar 

2. Zoom and Pan Toolbar 

3. Graph Toolbar 

4. Grid line 

5. The left vertical axis 

6. The right vertical axis 

7. Graph line 

8. Floating line 

9. The horizontal axis 

10. The readings for the current floating line 

11. Legend 

12. Graph background 

13. Page background 

14. Graph list window 

15. Statistics window 

16. Data table window 

17. Main menu 
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Open File 
Click on the second icon on the standard toolbar or click on the Main Menu->File->Open to open the *.dlg 

or *.mdlg file.  

 
 

Add File and Multi-Graph Mode 
The software can support several files are shown in a graph interface. User can click on the third icon or 

Main Menu->File->Add File to add files to current graph interface. User can compare and analyze the 

files using this function. 
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The graph line with A letter is a file, and the graph line with B letter is another file. User can save it to a 

new *.mdlg file. Note that the *.mdlg file need the original *.dlg file to graph correctly. 

 

Zoom and Pan 

 

 

 Zoom and Pan Method 
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-Auto  Zoom and pan in any direction 

-Horizontal  Zoom and pan only in horizontal direction 

-Vertical  Zoom and pan only in vertical direction 

-Manually  Set the start time and end time for horizontal axis, and set the scale for the vertical axis. 

 

 Zoom In and Pan 

- Use the mouse to click and drag a box around any graph area to magnify the area selected. 

-Press and hold the mid-button of the mouse at any graph location, and move the mouse to pan the 

graph area. 

 Zoom Out 

 

-Click on the Undo Last button to show last graph area. 

 

-Click on the Undo All button to show the original graph area. 

 

 Refresh 
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Export and Save 
The software can save and open the *.dlg or *.mdlg file type in default. Use can also save as other file 

types, including *.txt, *.csv, *.xls, *.bmp, and *.jpg.  

 

User can click on the Main Menu->Edit->Copy to copy the graph area to clipboard. 

 

 

Graph List  
User can use the graph list window to operate file and channel related functions easily. 

-Add or remove file using right-button of the mouse at file area of the tree. 

 

 

-Open the channel related settings at channel area of the tree. 
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-Show or hide the selected graph line. 
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Statistics Window 
The window will show the data logger information and statistics of readings 

 

 

Data Table 
The window will show the readings in table 

 

 

Print 
To print the graph, statistics and data table, click on the printer icon on standard toolbar or select Print 

from the File pull-down menu.  

User can also select the printed contents in the following dialog. 
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Graph Settings 
To set the graph area, click on the Graph Settings icon on graph toolbar or select graph settings from the 

graph pull-down menu.  

 

 

Mark Data Points 
Click right-button on graph area to show the pop-up menu below, Click “Mark Data Points” to show marks 

on all sample point locations. 
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Add Comment 
User can add comment at any location of graph area, and also add comment for any sample points. 

 

 

Units Conversions 
To create new unit and sub-unit, click on the units conversions from the tool pull-down menu. 
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Compound Line 
User can create new graph data and line via expression and the readings from data logger. Click on the 

compound line from tool pull-down menu.  

 


